settingsLogin | Registersettings
Es tu primera visita? Te invitamos a visitar nuestra sección de preguntas frecuentes FAQ!
x
Show Menu

Error al tratar de ejecutar cmdlet Search-Mailbox en módulo Power Shell de Exchange 2010

0 votos

Hola a todos,

Hoy al tratar de correr un script para eliminar cierto correo de todos los buzones me sale un error que no permite que el script se ejecute. EL script que estoy tratando de ejecutar es el siguiente:

Get-Mailbox -OrganizationalUnit "Administrativos" -ResultSize unlimited | Search-Mailbox -SearchQuery subject:"Proceso de seleccion" -DeleteContent

El error que recibo es:

Search failed on mailbox 'midominio\Juan Perez\651f6b64-479b-4923-abf7-1d95097cc287'. If the search query used short words with wildcard characters such as pat*, it can result in a large number of words or phrases because all permutations of words starting with "pat" are searched. Make search queries as specific as possible when using wildcard characters.

+ CategoryInfo :ReadError: (0:Int32) [Search-Mailbox], SearchMailboxException
+ FullyQualifiedErrorId :FCB4D87F,Microsoft.Exchange.Management.Tasks.Searc hMailbox

Ese mismo script yo lo ejecutaba perfectamente la semana pasada. Qué debo hacer para evitar que este error no me deje ejecutar ese script?

preguntado por 00melvin (208 puntos)   Feb 25, 2013
editado por 00melvin Feb 25, 2013

1 Respuesta

0 votos

00Melvin:

Intenta ejecutar este comando: Test-exchangeSearch

Puede que tengas el servicio "Microsoft Search (Exchange)" deshabilitado, que depende de "Microsoft Exchange Search Indexer".

Corroboralo y luego me cuentas !

Exitos.

respondido por Gustavo.Rodrigo (4,555 puntos)   Feb 26, 2013
Hola Gustavo, gracias por responderme. Antes de preguntar ya había verificado los servicios relacionados con la búsqueda "Microsoft Search (Exchange) y "Microsoft Exchange Search Indexer". Estaban corriendo normalmente. Pero sucede que hoy todo comenzó a funcionar bien, y no he cambiado nada. Ya ese cmdlet no me da error. Lo único diferente que veo es que en el event viewr hay eventos informando que se actualizaron varios componentes del hub-transport. No sé como se relaciona eso, pero ya todo está solucionado. Gracias por responder Gustavo!
...